Knowledgebase

From Documentation
Revision as of 16:34, 5 February 2015 by Adam (Talk | contribs) (Restoring an Autosave)

Jump to: navigation, search

Welcome to NetObjects Fusion knowledgebase

Sales Questions

Questions about purchasing NetObjects Fusion.

Where can I purchase NetObjects Fusion?

You can purchase NetObjects Fusion from our website. We invite you to take a look at all the great new features at our website, please click here.

What is Templates volume 4?

Templates Volume 4 includes dozens of complete design layouts, page content, amazing open-source plug-ins like Lightbox, a Sharebar and searchable form fields. You'll also receive a collection of high quality, licensed graphics from our Fotolia collection that will put your sites ahead of the pack. All you do is add content - we've taken care of the rest.

Where can I purchase Templates volume 4?

Take a look at some samples of the templates in action, just as you will receive them.

Upgrade Questions

FAQs about upgrading NetObjects Fusion

What versions of NetObjects Fusion can be upgraded?

You can upgrade to NetObjects Fusion from any version of NetObjects Fusion! The NetObjects Fusion installer will automatically search for a previous version installed on your computer. If the installer does not find a previous version installed, you will be prompted for your previous version’s serial number.

I’m being prompted for a serial number during the upgrade. Why?

You must have a Full Version serial number, or have a previous Full Version of NetObjects Fusion already installed, to upgrade NetObjects Fusion.

Where can I find my serial number for a previous version of NetObjects Fusion?

Your NetObjects Fusion serial number is located on the CD sleeve shipped in the box, or is included in the order confirmation e-mail that you received from the NetObjects Online Store.

You may also find the serial number by opening the older version of NetObjects Fusion and select Help then About NetObjects Fusion from the menu.

Find-serial-number-in-nof.jpg

If you have misplaced your serial number, please contact our Support Center.

How do I move my websites from my previous version of NetObjects Fusion to my new version of NetObjects Fusion?

We've put together migration instructions that will help you make the move as effortless and trouble-free as possible. If you experience any difficulties moving your sites from NetObjects Fusion 9, 10, 11, XII or 2013 feel free to contact our technical support department.

NetObjects suggests using templates for site migration when upgrading or moving your website projects. A template is a compressed copy of your site project that contains all assets used by your site. Web sites created in NetObjects Fusion can be migrated using the following procedure:

Save a backup copy and re-optimize your existing site:

  1. Open your site in your previous version of NetObjects Fusion.
  2. From the Tools menu, choose Save Site As.
  3. From the Tools menu, choose Re-Optimize.
  4. From the File menu, choose Save to ensure that the re-optimized site is saved.

Export your site as a Template:

  1. Switch to the Assets view to display all of the sites file assets.
  2. From the Assets menu, select Verify All File Assets.
  3. If you would like to remove unused file assets from your site, from the Assets menu select Delete All Unused File Assets. (This is recommended for optimum performance.)
  4. Switch to the Site view to show the site structure.
  5. From the File menu, choose Export as Template > Entire Site.
  6. In the dialog that appears, navigate to your Templates folder or any folder that you would like to use and save your template file.

Import your template into NetObjects Fusion:

  1. Launch Fusion.
  2. From the File menu, select New Site > From Template.
  3. In the dialog that appears, navigate to the folder where you saved your exported template.
  4. Click on the template that you wish to import and choose a name for your imported site.

Can I run multiple versions of NetObjects Fusion on the same computer?

You can run NetObjects Fusion on the same computer as any previous version of NetObjects Fusion software.

I opened my site in NetObjects Fusion and now I can’t open it in an older version of NetObjects Fusion. Why?

NOD files opened with newer versions of NetObjects Fusion will not be backward compatible with previous versions of NetObjects Fusion. We strongly recommend you make a backup copy, or Template, of all NOD files prior to opening them with your latest installed version. Creating a Template will ensure that you have the capability to open them with the previous version in the event you wish to do so. As a precaution, NetObjects Fusion will prompt you to save a copy of any .nod file that is opened directly.

Using NetObjects Fusion

Adding retired SiteStyles into NetObjects Fusion

Even though your site is not using a retired SiteStyle, you still miss them anyway. We understand and won't judge. If you have a previous version of NetObjects Fusion installed, you can copy the SiteStyles into the latest version.

NetObjects Fusion by default stored the SiteStyles in this directory:

C:\Documents and Settings\All Users\Documents\NetObjects Fusion XX.0\Styles

You can add the ones you miss to NetObjects Fusion by copying & pasting them into the corresponding following directory:

C:\Users\Public\Public Documents\NetObjects Fusion XX.0\Styles

General Maintenance Steps

Please follow these steps to ensure the integrity of your site project files. These steps will eliminate a variety of possible questions you may run into, we suggest following these steps before contact support.

You are using the most recent version of NetObjects Fusion.

Please visit http://netobjects.com/html/downloads.html to view the latest updates. If you are not on the latest version of NetObjects Fusion, follow this procedure to check for updates:

The latest version of Oracle's Java 32bit JRE is installed.

Visit http://java.com/en/download/installed.jsp using Internet Explorer. If you are not up-to-date, install the Windows Offline (32bit) JRE from here: http://java.com/en/download/manual.jsp.


Java-jre-32bit.png

NetObjects Fusion is configured to use the installed version of Java.


Verify-java-settings.png

How do I center my pages in NetObjects Fusion?

Centering your Website pages increases the readability of your content over a broad range of devices and resolutions. In NetObjects Fusion it's as easy as marking a checkbox.

  1. Open your site to the page view and click on any blank area in the Layout.
  2. The Properties pane will now show the Layout Properties.
  3. Select the option for Center in browser.
  4. Repeat this step for all your Website pages that you want centered.

Application crash

Please open the site project in your older version of Fusion, navigate to the Style View and remove all Active but unused SiteStyles.

Remove-unused-but-active-sitestyles.png

Re-export the site as a template & try to "Open as Template" in NetObjects. If that doesn't solve the problem, open the site in the older version, go to the Style View and select the CSS Code tab.

Css-code-style-view.png

Scroll to the bottom and note the total lines of CSS code. If the total is greater than 1,000 or so, the issue is the CSSParser causing the application to crash.

We are aware that under certain circumstances a large website, migrated from older versions of Fusion, may exhibit this behavior. We are working on a solution and apologize for your inconvenience. In older versions of Fusion, the application produced CSS code for every available component, whether they were actually used or not. As a result the CSS was bloated with unnecessary code. When you attempt to migrate the site, the CSS Parser chokes on the volume.

While we're working on a software patch to address the issue, you may follow these steps and use a free utility to compress and optimize the redundant code.

  1. In Style View, un-check "Read only".

Sitestyle-read-only.png

  1. Go to the CSS Code tab and select all the code (left click the mouse at the beginning and while holding down the left mouse button, drag to the botton of the CSS Code).

Css-code-style-view.png

  1. While the CSS Code is selected, hold down the Control button on your keyboard and press c to copy the code. ( CONTROL + C)
  2. Go to this website: http://www.cleancss.com and paste your copied code into the CSS Input section.

Cleancss.png

  1. Keep the default settings and click "Process CSS".
  2. Copy the compressed and optimized CSS Code.
  3. Return to NetObjects Fusion. Delete all of the CSS Code in the SiteStyle and paste the optimized CSS with the keyboard shortcut ( CONTROL + V)
  4. Save the site, export as template & open in NetObjects.

Creating a new publish profile

  1. Open your website and navigate to the Publish view.
  2. From the View menu, choose the Settings option.
  3. Click the New button to create a new publish profile.
  4. Fill in the following fields:
    • Server Type - This should default to FTP
    • Profile Name - Provide your profile a name that is different from your original profile name. You'll be selecting it when you publish your site.
    • Server - Your Server address or IP number provided by your web host.
    • Directory - If your web host requires a directory, input it here.
    • User Name - Your username provided by your web host.
    • Password - Your password provided by your web host.
    • Live URL - Optional, this will automatically open a browser and send you to the uploaded website address you specify.
  5. Once filled out, click Close.
  6. From the View menu, choose the Publish Site option.
  7. The Publish Site dialog opens, choose your new profile from the list under Publish files to.

Restoring an Autosave

  1. Using Windows Explorer, navigate to the following directory:

C:\Users\[USER NAME]\Documents\NetObjects Fusion [VERSION NUMBER]\User Sites\[YOUR USER SITE FOLDER]

  1. Click into the Autosaves directory.
  2. Locate the latest autosave, they are sequentually numbered.
  3. Right click and copy the file.
  4. Back up to the user site folder.
  5. Paste the backup here.
  6. Open NetObjects Fusion.
  7. Click File > Open > Browse for your user site folder.
  8. Open the backup file.

Note: If the latest backup is also corrupted, repeat the process above copying a backup from earlier.