Setting Application Options

From Documentation
Jump to: navigation, search

Setting Application Options

Application option settings affect all sites you work on in NetObjects Fusion. You can change settings from any view by choosing Options > Application from the Tools menu. Changes take place as soon as you click OK to close the Application Options dialog.

For information about site-specific settings, see Setting Options for the Current Site.

Setting Program Options

From the Tools menu, choose Options > Application. The Program tab of the Application Options dialog appears.

  • Auto save. When this option is selected, your website is saved each time you change views or web pages. If you clear the Auto save check box, be sure to save your website periodically by choosing Save Site from the File menu. However, with the Auto save check box cleared, upon exiting the application you will be prompted to choose whether to save the changes to your website or to cancel the closing operation.
  • Application window maximized at startup. If you clear the check box for this option, the NetObjects Fusion window opens in the last size you set, rather than full screen size.
  • Open to most recently used file at startup. When this option is selected, the last website you worked on opens automatically when you start NetObjects Fusion . If Open to most recent view is also selected, the website is displayed in the last view you worked in. If this option or Open to most recent view is cleared, you see Online view when you start NetObjects Fusion . If you switch to another view before opening a website, you see View tips.
  • Open file to most recent view. If this option is selected, when you open a website, it is displayed in the last view you worked in.
  • Use small fonts in properties panel. If you clear this check box, you see larger properties panels in Page view. To maximize the area available for your page Layout, leave this option selected.
  • Compact database upon exit. This option is selected by default. Compacting the files can save you substantial hard disk space. In addition, when this option is selected, NetObjects Fusion performs an error-checking procedure to verify your database as it compacts the files. It is recommended that you do not change this setting.

Do not shut down Windows while the file is being compacted. This could cause your .nod file to become unstable.

  • Edit locked objects. You can override locking permissions on a website by selecting this option. This allows you to edit a website without having to unlock each locked piece individually.
  • External file editors. You can select default applications for editing .html, .gif, and .jpg files from within NetObjects Fusion. You launch the default HTML editor by right-clicking the external HTML's icon in Page view and selecting Open File In External Editor from the shortcut menu. You launch the default image editor by right-clicking the image in Page view or Style view or the image name in Assets view, and selecting Open File In External Editor from the shortcut menu. To choose an external file editor, click Browse and find the file that launches the application.
  • Auto-generated image output. In most cases, when you add an image to a SiteStyle, crop an image, tile an image, rotate an image, create a transparent .gif, or add text to a shape or picture, NetObjects Fusion generates a new file, referred to as an auto-generated image. You can minimize the time it takes for the images to download by setting the Auto-generated image output. You can create output settings in Site view or in the Picture Properties panel.
  • Measurement units. Choose the measurement unit you want to use as you build your website. Choose pixels for the most consistent results independent of monitor resolution.

Setting Preview Options

From the Tools menu, choose Options > Application and click the Preview tab.

  • Select previewing default. When you install NetObjects Fusion, it lists the browsers installed on your system. If installed browsers are not listed, you can add them to the list. Choose the Web browser you want to use for previewing websites by selecting its check box. To change the browser used for previewing, return to this dialog and choose a different browser.

To add a browser to the list, click Add. In the New Browser dialog, type a name for the browser, browse to the shortcut or .exe file that launches it, and click OK. To remove a browser from the list, select it in the list and click Remove. To change a browser's name or location, select the browser in the list and click Edit. Enter the new information and click OK.

  • Preview scope. Choose whether you want to preview only the current page or the entire website you are working on when you click the Preview button on the views bar. Previewing the entire website takes longer, but you can move from page to page in the browser to test the website's navigation buttons. Select the Current page option to preview only the current page. When you select Current page, links to other pages are disabled. You can also preview the current page by clicking the Page Preview tab in Page view.

You can use keyboard shortcuts to preview either the whole website or just the current page or section:

  • If Entire site is selected in the Application Options dialog, pressing Alt+P or clicking the Preview button previews the entire website; pressing Ctrl+Alt+P or clicking the Preview button while pressing Ctrl previews just the current page.
  • If Current page is selected in the Options dialog, pressing Alt+P or clicking the Preview button previews the current page; pressing Ctrl+Alt+P or clicking the Preview button while pressing Ctrl previews the entire website.
  • Window size. Select the window size or resolution most appropriate for your website visitor's monitors. This opens a preview window sized to the resolution you select so you can see how website visitors will view your website.

Setting Text Options

From the Tools menu, choose Options > Application and click the Text tab.

  • Browser font settings. To ensure that your web pages appear in your browser the way you design them in NetObjects Fusion, choose the same font settings in your browser that you use in your website. For example, if you use Times, size 12, and Courier New, size 10, for your browser proportional and fixed width fonts, choose the same fonts and sizes in NetObjects Fusion. The suggested settings are the defaults used by modern browsers.

These settings do not change the actual font for the HTML generated by NetObjects Fusion; they only mimic the effect of a font change. To change the font, see Modifying a Text Style. NetObjects Fusion sizes text boxes based on the expected font size, so when you change sizes, you change the Layout of the web page slightly.

  • Automatically select entire word. If this option is selected, when you start to drag the mouse pointer over a word, NetObjects Fusion automatically selects the entire word and the space after it.
  • Smart spell check. If this option is selected, after NetObjects Fusion checks spelling of a text block, it does not check the same text again unless you modify the text or clear this option.
  • Check Spelling as you type. If this option is selected, NetObjects Fusion will check the text as you type, and then mark possible errors with wavy underlines. To make a correction, right-click on the word and select the correction you want.
  • Display Report Message. If this option is selected, after NetObjects Fusion spell checks the web page or website, you will see the number of corrections made. If you find this option unnecessary, you can also check the "Don't display again" box after spell-checking your web page.

Setting International Options

From the Tools menu, choose Options > Application and click the International tab.

  • Date, time, and decimal formats. The date, time, and decimal formats you select affect how these items are displayed wherever they appear in NetObjects Fusion; for example, the last published date of items in Publish view. These settings do not affect generated HTML or text you enter on Web pages.

Select a format from the Date/time drop-down list. A sample of the format is shown next to each language. To determine the decimal point character, select a format from the Decimal drop-down list. If you choose Use System Setting for either option, NetObjects Fusion uses the setting in the Windows Regional Settings Properties dialog.

  • Spelling dictionary. Select the dictionary you want to use when checking spelling.
  • Sort order. Character variations between languages result in variations in sorting priorities. To ensure that items in Assets view and Publish view are sorted correctly, you can choose the appropriate sort order. This affects only how the items are displayed in NetObjects Fusion; it does not affect the generated HTML. If you choose Use System Setting, NetObjects Fusion uses the current system sort setting.
  • Imported text uses character set. Choose the character set you want to apply to text in imported sites. For information about character sets, see Working with Character Sets.

Updating NetObjects Fusion

From the Tools menu, choose Options > Application and click the Updates tab. Set your preferences for checking for online program updates. Select Automatically to check for updates using the frequency and event you specify, or Manually to check only when you select Check for Updates form the Tools menu. Automatically is the default setting. If you select Automatically:

  • Select an update frequency of Daily, Weekly, or Monthly.
  • Choose when you want to check for updates. Select:
  • Launches to search for updates each time you start NetObjects Fusion.
  • Connects to the Internet to search for updates when you connect to the Internet while using NetObjects Fusion. This is the default setting.

Setting Preferences

From the Tools menu Choose Options > Application > Click the Preferences tab. Use the Preferences tab to determine a variety of default options and warning displays. Choose what warnings to appear when publishing or when working with pop-up windows and tables. Set color picker options to only display Web safe colors or to include the color table when setting color preferences. Modify locking and meta tag preferences to maximize productivity.

  • Color Picker Preferences: You can set color options, such as whether or not to show Web colors and the color-table, on the Color Picker dialog.
  • Lock Preferences: Select the messages you want to be displayed when a certain action is taken with one or more objects you have selected to protect.
  • Meta Tags Preferences: You can enable and disable warnings with "apply to all" setting, warnings on multiple overwrite, or warnings on inheritance.
  • Popup Preferences: You can choose to show a warning dialog before a pop-up window is removed.
  • Publish Preferences: Select what warnings to be displayed when folders (either empty or containing data) are deleted.
  • Table Preferences: Select what warnings you want to be displayed when working with table elements.

Any changed preference will also be registered in the object's settings from the Properties panel.