Optimizing Your Workspace

From Documentation
Jump to: navigation, search

Optimizing Your Workspace

The NetObjects Fusion user interface offers a new powerful, yet simple, mechanism of panels, toolbars, and menu customization, enabling Web designers to take full advantage of optimizing their workspace for maximum efficiency.

Create new toolbars and menus, and customize them by adding new buttons and menu items, changing button icons, and much more. Take advantage of the new docking panels offered to construct the working area that best suits your needs, by moving, floating, docking, and hiding panels within your workspace.

Save the position and customizing options of toolbars, menus, and panels as a new workspace, or choose among the predefined workspaces that NetObjects Fusion offers.

Change the look and feel of your workspace by selecting among the themes that are available with NetObjects Fusion.

Selecting a Workspace

With NetObjects Fusion, the workspace concept is introduced for optimizing your work area. The workspace consists of all the panels, toolbars, and menus within NetObjects Fusion.

NetObjects Fusion displays the Basic workspace by default:

  • Basic, which displays a reduced number of panels and toolbars for quick and easy use, consistent with the way previous versions of NetObjects displayed these items. See Selecting the Basic Workspace.
  • LastUsed, which displays the last used configuration for panels, toolbars, and menus that are saved before you have existed NetObjects Fusion. See Selecting the LastUsed Workspace.

You can create your own workspace by displaying only the panels and toolbars that you need, in the precise positions you want them to appear. Then, you simply save the new workspace configuration and the select it from the list of available Workspace options in the menu when you are ready to work with your new environment. See Creating a Custom Workspace.

Selecting the Basic Workspace

The Basic workspace is best suited for users who have just begun working with NetObjects Fusion, as it displays panels and toolbars that are most commonly used.

To display the Basic workspace, select it from then View > Workspace menu.

Selecting the LastUsed Workspace

The LastUsed workspace remembers the contents and coordinates of the workspace as they were when you closed NetObjects Fusion. It is saved only when exiting NetObjects Fusion; when you re-start Fusion, it will load the LastUsed workspace, as it was at the moment the program was closed.

When first installed, NetObjects Fusion opens with the Advanced workspace by default. When exiting the program, the current configuration of panels and toolbars will be saved and kept as the LastUsed workspace and loaded as the new default the next time you launch NetObjects Fusion.

To display the LastUsed workspace, select it from then View > Workspace menu.

Creating a Custom Workspace

To create the work area that is most efficient for the way you work in NetObjects Fusion, or to create a workspace that is beneficial to specific projects, arrange the panels and toolbars to your preference and save the workspace so it can be re-used over again when needed. Each workspace that you create and save will appear on the Workspace list in the View menu.

To do that:

  1. Display all the panels and toolbars that you would like to work with in NetObjects Fusion.
  2. When the workspace has the layout you desire, from the View menu select Workspace > Save Workspace as... The Save As dialog appears.
  3. Type the name of the new workspace. If there is already a workspace with that name in existence, you will get a warning message asking you if you want to replace the existing workspace. Select No and rename the workspace, or select Yes to overwrite the existing workspace.

The new workspace name will appear on the Workspace list in the View menu.

To open a custom created workspace, select it from the View > Workspace menu.

Displaying and Hiding All Panels

For increased work space, you can hide all panels displayed within your workspace. This will affect only the panels, without hiding the toolbars currently displayed.

To do that, select the Full Screen option from the View menu. The effect will be that all panels including those that are docked, will be hidden.

To have the panels displayed again, select the Full Screen option from the View menu one more time.

The same result will be obtained if you display and click the Full Screen button on the toolbar.

The Full Screen bar is disabled by default. To display it:

  1. Click on any toolbar's right arrow button, and then select Customize from the menu. The Customize window will appear.
  2. From the Toolbars tab, check the Full Screen option.

Working with Panels

NetObjects Fusion comes with a new and innovative system of panel management, offering you a variety of possibilities to display only the necessary tools you need when you need them. Your available workspace may be increased considerably by the arrangement of panels. Optimize the layout of your workspace by:

  1. Displaying or hiding all panels. NetObjects Fusion offers you a one-click solution to choose whether or not all panels should be displayed within your workspace.
  2. Docking panels. You can dock panels to the left, right, top, or bottom of the workspace.
  3. Floating panels. Floating panels may be moved freely to any location within the workspace; they can appear on top of, or behind, other floating panels.
  4. Working with panel groups. Panels may be grouped together to form panel groups. These groups of panels will behave as regular panels; they can be docked or left to float.
  5. Auto-hiding panels. To save space, panels can be made to hide automatically when not in use.

The panels that are used most frequently within NetObjects Fusion are listed on the View menu. To see the rest of the available panels, select More Panels from the View menu. To open a panel that is not displayed in the workspace, go to the View menu and select it from the list.

Clicking the Close button on a docked or floating panel will remove it from the interface. To re-open a panel once you have closed it, select the panel's name from the View menu.

Docking Panels

Within the NetObjects Fusion workspace, panels may be:

  • Docked. A panel is docked if it is attached to a side of the workspace.
  • Floating. A panel is floating if is not attached to any side of the workspace and can be positioned on top of other panels.

Panels may be docked either to the inner and outer edges of the workspace or to the edge of another panel.

The docking procedure is based on drag-and-drop. When you drag a panel from its current location to another location in the workspace, a translucent set of directional stickers will be displayed on the workspace.

Dropping the panel on one of the outer stickers will allow you to dock the panel to the outer edge of the workspace. Dropping the panel on one of the inner stickers will dock the panel to the inner edge of the workspace.

To dock a panel to the outer edge of the workspace:

  1. Drag the panel by its title bar and move it over one of the outer stickers, according to the desired destination area.
  2. When the mouse cursor is over the sticker, an outline of the panel will appear.
  3. Release the mouse button.

The panel will now be docked to its new position, as suggested by the outline.

To dock a panel to the inner edge of the workspace:

  1. Drag the panel by its title bar and move it over one of the four inner stickers, according to the destination area.
  2. When the mouse pointer is over the sticker, an outline of the panel will appear.
  3. Release the mouse button.

The panel will now be docked to its new position, as suggested by the outline.

To dock the panel relative to another panel (tab-link two panels):

  1. Drag the panel over another panel (or group of tabbed panels).
  2. The inner group of stickers will appear. A small tabbed panel will be visible in the center of the stickers group, indicating the ability to add the panel as a tab.
  3. While still holding the mouse pointer down, move the panel over the center of the stickers group. You will have a preview of how the panels will look when tabbed.
  4. Release the mouse button.

Floating Panels

Floating panels are stand-alone panels that can be moved to any area within the workspace. They will stay on top of other panels and can also be docked to any side of the workspace.

Floating panels are best suited for a large screen with enough space for displaying both the panels and the page layout.

To make a docked panel float:

  1. Drag the panel by its title bar, away from where it is docked.
  2. While still holding the mouse button down, move towards the destination area.
  3. Release the mouse button.

To float a group of docked panels:

  1. Drag the group by its title bar.
  2. While still holding the mouse button down, move towards the destination area.
  3. Release the mouse button.

Groups of docked panels travel together.

To change the location of a floating panel in the workspace, simply drag it by its title bar to the desired destination.

To float a panel from a group:

  1. Drag the panel's tab away from its tabbed group.
  2. While still holding the mouse button down, move the panel by its tab outside the group, and away from the edges of the workspace.
  3. Release the mouse button.

Working with Panel Groups

Panels may be stacked together to form groups of panels. To display a panel contained in the group, you simply click the name tab of the panel that is visible in the group.

A panel may be tabbed with another panel or a group of panels by:

  • Dragging the panel by its title bar and placing it over the destination panel's title bar. A preview of how the docked panel will look appears. When the preview appears, release the mouse button.
  • Dragging the panel by its title bar and placing it over the center of the destination panel when the inner set of directional stickers appears.

If a panel is part of a group of panels, it can be removed from the group at any time to form a stand-alone panel.

To remove a panel from a group of panels:

  1. Drag the panel's tab outside the tabbed panel area.
  2. While still holding the mouse button down, move towards the desired destination area.
  3. Release the mouse button.

To move a group of tabbed panels, simply drag the group by its title bar to the new destination area.

Using AutoHide

In order to have more screen space, it may be desirable to temporarily hide some of the panels. To suit this purpose, panels support the AutoHide feature that enables you to minimize docked panels along the edges of the workspace when not in use.

By clicking a button, panels may be collapsed to a tab, from which they can be expanded back into place by hovering the mouse pointer over the tab.

To turn on/off AutoHide, click the push-pin icon on the title bar of the panels.

The AutoHide feature is available for both docked and floating panels:

  • AutoHide docked panels. When a docked panel is set to minimize using the push-pin and you move the mouse over its tab, the panel expands to the area where it was last docked.

When an auto-hidden docked panel loses focus, it automatically slides back to its tab, where its name remains visible.

To display an auto-hidden panel, move your mouse over the tab. The panel will slide back into view.

  • AutoHide floating panels. When a floating panel is set to minimize using the push-pin and you move your mouse over its title bar, the panel will expand.

When an auto-hidden floating panel loses focus, it automatically slides under its title bar. While a panel is auto-hidden, only its title bar will be visible in the workspace.

To display an auto-hidden floating panel, move your pointer over its title bar or click on it. The panel will slide back into view.

Working with Toolbars

Along with the new concepts of panel management within the workspace, NetObjects Fusion also offers a powerful toolbar customization mechanism that allows you to create a working environment that suits your needs.

Now you can:

  • Display and hide toolbars, add and remove toolbar buttons, and change the location of toolbars within the workspace, as well as docking them and making them float. See Using Toolbars.
  • Create your own custom toolbars, and rename or remove them from the workspace. See Managing Toolbars.
  • Access and organize commands on toolbars quickly and easily. See Adding Commands to Toolbars.
  • Add new buttons to toolbars; change button icons by selecting from the existing ones or create your own new icons; choose to display only text commands or buttons, or display both text and icons; and much more. See Customizing Toolbar Buttons.
  • Switch to display large icons on the Views toolbar, or select to display tooltips on your toolbar icons. See these options and additional ones in Working with the Options Tab.

Using Toolbars

Toolbars allow you to access and organize commands quickly and easily. You can change the location of toolbars within the workspace, by docking them or making them float, in order to create the working environment that is best for you.

Toolbars may be held in two modes within the workspace:

  • Docked, when they are attached to one edge of the work area. You can dock a toolbar to the left, right, top, or bottom edge. When you drag a toolbar to the edge of the window, the toolbar snaps into place in the vertical or horizontal position of the window's edge.
  • Floating, when they are not attached to any edge of the work area. When floating, a toolbar may be placed on top of other objects or other floating toolbars. Resizing a floating toolbar will make the icons rearrange on the toolbar.

When a toolbar is made to float, the grip handle disappears from the toolbar and the name of the toolbar will be visible on its title bar.

You can move toolbars within the workspace to position them in the place that is best for you.

To move a toolbar:

  1. Drag the toolbar by its grip handle if it is docked, or by its title bar if it is floating.
  2. While still holding the mouse button down, move the toolbar to the new destination location. If you drag the toolbar to the edge of the work area, it will dock to the edge.
  3. Release the mouse button.

To increase and improve the layout of your workspace, you can decide which toolbars should be displayed on your workspace. To do that, select from the View menu the name of the toolbar you want to be displayed on the workspace.

You can optimize the use of toolbars by displaying only the buttons that you normally use. You will be able to add more buttons to toolbars at any time in the future.

To add or remove a button from a toolbar:

  1. Click the Toolbar Options button on the toolbar you are working with.
  2. From the Add and Remove Buttons menu, select the toolbar you want to modify.
  3. From the list of buttons that appear, check or uncheck the button.

You can also reset the toolbar to its default state by selecting the Reset option.

Managing Toolbars

NetObjects Fusion comes with a powerful, yet simple, toolbar management system. You can create your own custom toolbars on which you add commands from the existing set of commands in the program, rename or remove custom toolbars, add menus on the toolbars, and much more.

All these options are possible through the Customize window.

To display the Customize window:

  1. Right-click anywhere on a toolbar.
  2. Choose Customize from the context menu that appears. The Customize window will be displayed.

You can also trigger the appearance of the Customize window by clicking the arrow on the right edge of a toolbar and selecting Add and Remove Buttons > Customize.

When the Customize window is displayed, NetObjects Fusion switches to the Customize working mode, in which normal actions within the program will no longer be functional until the Customize window is closed. The Customize mode will allow you to create new toolbars, add commands and menus to existing toolbars, change button icons, and much more.

The Customize window contains three tabs:

  • Toolbars, where you create new toolbars and manage the existing ones.
  • Commands, where you add new commands and menus to existing toolbars. See Adding Commands to Toolbars.
  • Options, where you can modify the look and behavior of toolbars and menus. See Working with the Options Tab.

When in Customize mode, click on a button on a toolbar and the button context menu appears, offering the ability to customize the selected button. To find out more, see Customizing Toolbar Buttons.

On the Toolbar section of the Customize window, you will see all the NetObjects Fusion toolbars listed, along with any new custom toolbars that you have previously created. Toolbars that are currently displayed on the workspace appear checked on the Toolbars list.

To display a toolbar, select the toolbar name check-box . To hide a toolbar, un-check the toolbar name.

Working with Custom Toolbars

NetObjects Fusion now offers you the ability to create your own custom toolbars for associating programmatic commands with the customized toolbar options you create.

To create a custom toolbar:

  1. In the Toolbars tab, click New. The New Toolbar dialog box appears.
  2. Enter the name of the new toolbar in the Toolbar Name field.
  3. Click OK.

The toolbar name will now appear in the list on the Toolbars tab.

The new toolbar also appears as a docked toolbar in the top part of the workspace.

Once they are created, custom toolbars may be renamed or even removed from the program.

To rename a custom toolbar:

  1. In the Toolbars tab, highlight the name of the custom toolbar you want to rename and click Rename.
  2. Enter the new name in the Toolbar Name field.

NetObjects Fusion built-in toolbars cannot be renamed.

To delete a custom toolbar:

  1. On the Customize window, select the Toolbars tab.
  2. Highlight the name of the toolbar you want to delete.
  3. Click Delete.

NetObjects Fusion built-in toolbars cannot be deleted.

When necessary, you can reset the content of a built-in toolbar to its default settings. To do that:

  1. Select the built-in toolbar. The Reset button will appear.
  2. Click Reset.

The default buttons will be restored to the toolbar.

Reset to default settings is an operation that can be performed only on built-in toolbars.

Adding Commands to Toolbars

The new and dynamic system of toolbar customization within NetObjects Fusion offers you the ability to change the toolbars content, by adding or removing commands that you choose from all the existing commands in the program. In this way, you can add commands to built-in and custom toolbars, move commands from one toolbar to another, or change the position of commands on toolbars.

The Standard Tools toolbar does not allow adding or removing commands from itself.

You can add commands to a toolbar by selecting a category from the Customize dialog and dragging the command onto the toolbar.

To add a command to a toolbar:

  1. Using the mouse, right-click on an existing toolbar and select the Customize option. The Customize dialog box will appear.
  2. Click on the Commands tab.
  3. Under Categories, click on Edit.
  4. A list of commands will appear in the list box under Commands. Scroll down and locate the command you want.
  5. Select and drag the command from the Commands list to the toolbar.

The selected command now resides on the toolbar.

To remove a command from a toolbar:

  1. While in Customize mode, click and drag the command button from the toolbar area.
  2. The command button now displays an X next to the mouse pointer to identify that the command is being moved.
  3. Release the button anywhere outside the toolbar area.
  4. The toolbar will no longer have the command button on it.

A built-in toolbar will allow you to reset to the default state after removing some of the buttons located on it. A custom toolbar does not allow the reset to default action.

To change the location of a command button on a toolbar:

  1. While in Customize mode, click and drag the command button from the toolbar and move it to another place on the same, or on a different, toolbar.
  2. Position the command button and release the mouse button.

In NetObjects Fusion, you can create and add new menus on a toolbar by dragging and dropping menus from the Commands tab onto toolbars.

Customizing Toolbar Buttons

NetObjects Fusion offers a new and innovative mechanism of button customization, allowing you to edit button icons and modify the look and feel of toolbars, all during run-time.

To use the new button customizing facilities within the program:

  1. Open the Customize window.
  2. While keeping the Customize window open, right-click on a toolbar button. The Button Context Menu will appear.

On the Button Context Menu you will be able to perform the following actions on the selected button:

  • Reset. Changes button settings to default. If you have previously changed the default settings for a button, you can revert to the default settings.
  • Delete. Removes the button from the toolbar.
  • Name. Modifies the button name by typing a new name in the name field.
  • Copy Button Image. Copies the button image from the toolbar it resides on. You can duplicate a command and have the command button on a toolbar different from the original one.
  • Paste Button Image. Pastes the button image to another toolbar, thus creating a duplicate button.
  • Reset Button Image. Changes button image to default. If you have previously changed the default image for a button, you can revert to the default image.
  • Edit Button Image. Provides a new button image using the button image editor, by either modifying the existing one or importing a new image file.
  • Change Button Image. Changes the button image with an image from the existing button images panel.

To edit the button image:

  1. Select the Edit Button Image option. The Button Image Editor will appear.
  2. Use the available tools to create the picture that suits your needs.
  3. Use the up, down, left and right arrows to move the image.
  4. Change the colors and preview all the changes you perform to the button image.
  5. When finished, click the OK button.

The new icon will be visible on the button.

To change the button image:

  1. Click the Change Button Image option on the Button Context Menu. The images panel will open and you will be able to preview the available images.
  2. Select a new button image from the panel.

The new icon will appear on the button.

By default, buttons on the toolbars display images that illustrate the commands associated with the buttons. In NetObjects Fusion, buttons on a toolbar may be customized to display images of the buttons on toolbars, the text of the commands only, or both the image and text of the commands by selecting one of the options below:

  • Text Only, which displays only the text of the command associated with each button, as displayed in the image below:
  • Image and Text, which displays the text and the image of the command associated with each button. The button will have both image and text on it.
  • Default Style, which displays only the button image. The button will have only the image on it:

You can group similar commands together on a toolbar by creating a group of commands. To do that, select the Begin a Group option from the Button Context Menu.

Working with the Options Tab

The Options tab offers options for customizing the behavior of menus within the workspace, as well as additional options.

In the Personalized Menus and Toolbars section from the Options tab, you can restore the default set of visible commands to the menus and toolbars without undoing any explicit customizing, by checking the Reset menu and toolbar usage data option.

On the Other section from the Options tab, you can:

  • Toggle the use of large icons, which allows you to display large icons on the Views bar.

To switch back to the normal-sized icons, un-check the Large Icons option.

  • Show ScreenTips on toolbars, which allows you to either turn ScreenTips on or turn them off. With ScreenTips on, cues will appear over your toolbar button as you scroll over them with the mouse, suggesting the command linked to that button. If the ScreenTips are off, no such cues will appear on mouseover.
  • Show shortcut keys in ScreenTips, which allows you to choose to show shortcut keys in screentips. To do that, select the Show shortcut keys in Screentips.
  • Select menu animations from the existing possibilities, allowing you to choose which animation effects will be applied to menus. To do that, choose one from six predefined effects available in the Menu animations drop-down box: System Default, Random, Unfold, Slide, Fade, and None.

Changing the Windows Theme

You can change the look and feel of the entire application by choosing a Windows theme. The style of toolbars, panels, menus, and all the other user interface controls will be updated to match the selected theme.

To change the Windows theme:

  1. From the Tools menu, select Theme and then one of the available themes.
  2. The new theme will be applied.

By default, NetObjects Fusion uses the Office 2007 theme.