Creating and Managing Sites

From Documentation
Jump to: navigation, search

Creating and Managing Sites

Site view is where you create, view, and maintain the architecture of your website. Site view frees you from the details of file and link management, so you can focus on organizing and updating your website. For example, you can drag a Web page or section to any location in Site view, and NetObjects Fusion updates the links to other Web pages automatically.

Starting NetObjects Fusion

When you install NetObjects Fusion, it is added to your Windows Start menu.

  1. From the Start menu, choose Programs > NetObjects > NetObjects Fusion.
  2. Follow the onscreen instructions to configure your system, or skip this for now and continue.
  3. You can use the Site wizard to create a site or go directly to NetObjects Fusion Online view.
    • If you choose the Site wizard, follow the onscreen instructions to create your site.
    • To create a blank site or open an existing site, see Creating and Opening Sites.
    • To create a new site based on a NetObjects Fusion template file, see Working with Templates.

After the first launch, you can set Application Options so NetObjects Fusion automatically opens the last website you worked on in the last view you used. See Setting Program Options.

Working with Site Files

A NetObjects Fusion site file is a relational database of information about your site. Site files have a .nod file extension.

Site files are stored in a folder that has the same name you give the site. For example, if you name the site MySite, the site's folder is called MySite, and the site file MySite.nod is saved inside the folder. The site folder contains an \Assets folder with the asset files used in the site, as well as a \Backups folder. Once you preview the site, a \Preview folder is added, and when you publish the site locally, a \Local Publish folder is added as long as you do not change the default local publish location.

By default your site folder is saved inside the \User Sites folder, but you can store the site in any location on your local computer. Because the paths to the assets in a site file are absolute they include the drive and folder names therefore you cannot save the site file on another computer on a network. To move a site to another computer, you must export the site as a template, as described in Working with Templates.

It's a good idea to check the size of your .nod files periodically. Some site designs may cause a sudden increase in the size of the .nod file. If this happens, choose Re-optimize from the Tools menu. This command can increase the efficiency of the open site file.

Creating and Opening Sites

When you create a site, you always begin with a template. You can also derive templates from sites you create.

A template is a fully designed page or site that you can use as a starting point for your own pages or sites. A typical template might include a banner and navigation buttons, an assigned SiteStyle, and text or other content. You can start a new site from a template or insert one into your current site. Once inserted into a site, you can modify template pages any way you like. Templates are described in detail in Working with Templates.

You can also open an existing site and add to it, change its style, or modify it.

Starting with a Blank Site

You can build a new website from a blank website, which is a template that consists of a Home page with a banner and navigation buttons. To start with a blank website:

  1. From the File menu, choose New Site>Blank Site.

The New Blank Website dialog appears.

  1. Enter a sitename in the dialog.
  2. Click Save.

Site view opens and displays a Home page. You can begin developing the SiteStructure, as described in Working with the SiteStructure.

Starting with the Site Wizard

You can also start a new site using the Site wizard.

  1. In Site view, from the File menu, select New Site > Using Site Wizard.

The introductory Site wizard dialog appears.

  1. In Step 1, choose a site Type and corresponding Style.
  2. Click Preview Style to view the style in a browser, or click Next.
  3. In Step 2, select pages and page layouts for your site.
  4. You can add pages, remove pages, or keep the pre-selected pages for your site type.
  5. In Step 3, enter personal and business information.
  6. To save this information in your profile for later use, click "Save to profile".
  7. Click Finish and type a name for your site in the Save Site As dialog.
  8. Click Save to build your site.

Once you have completed the site wizard, you can edit your site at any time.

Opening an Existing Site

  1. From theFile menu, choose Open Site.

The Open dialog appears.

  1. Open the folder that contains the website you want to open.
  2. Select the website's .nod file and click Open.

You can also open an existing website by:

  • Choosing it from the list of recently used web site files on the File menu.
  • Choosing it from the list of websites in Online view.
  • Double-clicking the .nod file in Windows Explorer.
  • Dragging the .nod file from Windows Explorer to the NetObjects Fusion window.

Working with the SiteStructure

In Site view, the structure of your website is represented by page icons. As in a family tree, pages have parent, child, and sibling relationships. In Site view you can add Web pages to the website, rename Web pages, move them, copy them, delete them, and complete other website-oriented actions. To add content to a particular Web page for example, to add text or pictures use Page view. As you construct a website, you typically go back and forth between Site view and Page view.

Selecting a Page

Before you can add, copy, rename, move, or set Web page properties, you must select a Web page. By selecting a Web page, you identify it as the one you will work with. NetObjects Fusion places a blue border around the selected Web page. To select a Web page:

  • Click the Selection tool on the toolbar and then click the icon for the page you want to select. Don't click the Web page's name unless you want to rename the Web page.
  • Press the arrow keys to select the current Web page's parent, child, or sibling pages.

Web pages that are excluded from the website navigation will have a red border and the line connecting the Web page to its parent Web page will be removed.

Working with a Group of Pages

In addition to selecting individual pages, you can select several pages and change their properties. You can select any combination of noncontiguous pages or you can select a section of your site, which is any page and all its children, their children, and so on.

To select noncontiguous pages:

  1. Click the first page to select it.
  2. Shift+Click additional pages to select them.

NetObjects Fusion places a border around each selected page and lists the pages on the Selected Pages section of the Properties panel.

To select a section:

  1. Click the parent page of the section.
  2. Shift+Click the parent page of the section or choose the Select Section option from the Edit menu.

NetObjects Fusion places a border around each page in the section and lists the pages on the Selected Pages section of the Properties panel.

Sections are not permanent entities. You can deselect the section by clicking any page in the site, or by clicking the Site view background.

Setting Properties

Pages have properties. Some properties affect the published site; others are for your information only. For example, you can assign colors to the page icons to create visual groups that indicate which pages are finished or which are assigned to a particular designer. You can instruct NetObjects Fusion not to publish a particular page, note if a page is done, and enter comments about the selected page. You can use META tags to include information about specific pages on each site. See Setting META Tag Properties.

Setting Page Properties

You set the following properties on the Page section of the Properties panel:

  • Page name. Name assigned to the page that is used on the page icon in Site view and the banners and navigation bar buttons generated by NetObjects Fusion. See Renaming Pages.
  • Page title. Text that appears in the title bar of the browser window when it displays this page. When site visitors bookmark this page, the page title is used. The title is also emphasized in search engine queries.
  • Custom Names. See Using Custom Button and Banner Names and File Extensions.
  • Page type. Shows whether the page is a normal page or a stacked page. You cannot change this setting; it is determined by how the page was created. For information about stacked pages, see Data Publishing.
  • MasterBorder. Shows the MasterBorder assigned to the page. You can change the Default MasterBorder by selecting ZeroMargins from the drop-down list.
  • Exclude From Navigation. Removes the page from the site navigation. The page is published and typically accessed using links. See Creating Links.

Setting Site Management Properties

Click the Management button to set the following properties:

  • Done. Page icon displays a check mark when you select Done. This is a convenient way to manage individual pages in a large site. This setting has no effect on the functioning of the site.
  • Don't publish. Makes it possible to publish some pages while not publishing others that might be under construction or private. The page icon displays a red indicator when you select Don't publish.

NetObjects Fusion removes pages marked Don't publish from the navigation bars of other pages in the site, disables manually created links to such pages, and does not generate HTML for these pages during publishing. However, you can preview a page that is designated Don't publish as an individual page.

Do not use the Don't publish setting in an attempt to publish only changed pages to an already-published site. Doing so causes broken links and other undesirable results. Instead, you can publish a section of the site to update it. See Publishing Your Site.

  • Color code. You can set the color of page icons in Site view to highlight a group of selected pages or pages that share the same MasterBorder. A page icon's color has no effect on the published site. You can display either a user-defined or MasterBorder color by opening the View menu, choosing Page Color Coding, and then choosing User Defined or MasterBorder. You select the colors to be displayed on the Management section of the Properties panel.

On the Management section of the Properties panel, click the:

  • User defined Color button to choose a color for the currently selected page or pages.
  • MasterBorder Color button to choose a color for pages that have the same MasterBorder as the currently selected page. This option is not available if multiple pages are selected.

For example, select a page and choose blue as the MasterBorder color and red as the user-defined color. From the View menu, choose Page Color Coding, MasterBorder. The icons representing all pages that share the MasterBorder of the selected page turn blue. If you create a new page and assign the same MasterBorder, that page icon is also blue. Return to the View menu and choose Page Color Coding, User Defined. The icon of the originally selected page now turns red and the other page icons return to the default color.

  • Comments. Enter notes about the status or content of individual pages. This option is not available if multiple pages are selected.

Setting Properties for a Group of Pages

When multiple pages are selected, you set properties on the Selected Pages tab of the Properties panel. You can change the properties for all selected pages or for a single page.

  1. In Site view, select the pages you want to work with. See Working with a Group of Pages.
  2. Choose a property from the top drop-down list. You can select:
    • MasterBorder to change the MasterBorder applied to the selected page or pages.
    • Page name to change the name of the page in Site view and the default names on the page's banner and navigation button.
    • Title to change the text displayed in title bar of the site visitor's browser and bookmark list.
    • Navigation button to change the text displayed on the button in the navigation bar that links to the selected page.
    • Banner to change the text displayed on the selected page's banner.
    • File extension. See Using Custom Button and Banner Names and File Extensions.
  3. Select a property value from the drop-down list, or type a value into the field.
  4. To apply the new value to all selected pages, click Set on all.

The new value is displayed in the list at the bottom of the panel.

You can also set Management properties for multiple pages. See Setting Site Management Properties.

Setting META Tag Properties

You can use META tags to include information about a site within the <HEAD> tag of each page in the site. For example, you might want to include keywords to promote your site with the various search engines, the site author's name, or copyright information. Site visitors do not see information included in a META tag.

You can set META tag properties at the page level or at the site level.

  1. In Site view, select the page you want to work with and click the META tags tab.
  2. Choose a META tag from the META tag drop-down list and insert the text you would like to associate with this META tag:
    • Abstract. Provide a brief summary or abstract of your website. This is normally a one or two sentence overview of your site.
    • Author. Declare the author of or organization associated with the web page being read.
    • Contact Address. Provide site visitors information about how to contact you or your organization.
    • Copyright. Place a copyright notice on all web pages of your site.
    • Date. Declare when the web page was created.
    • Description. Provide a general overview of what is contained in your web page. This is the content displayed by search engines.
    • Distribution. Define how your web page will be categorized on the web in terms of intended audience.
    • Expires. Sets an expiration date and time of the web page being indexed.
    • Generator. Declares the application used to generate the web page's META tags.
    • Keywords. List a series of terms representing the content of your site. Some search engines use keywords to categorize sites.
    • Language. Declare the language of your web page.
    • Public. Declare if the web page is available to the public.
    • Rating. Define the content level of your site to screen out inappropriate viewers.
    • Refresh. Define the number of seconds before refreshing or redirecting your web page.
    • Revisit After. Define how many days a search engine spider should revisit your web page.
    • Robots. Declare to search engines what content to index and spider.
  3. Click on the text field and enter your content.
  4. To apply these META tags to all child pages, click "Inherit META tags from parent". If you make changes to the META tags on a page in which they were inherited, "Inherit META tags from parent" will no longer apply.

If you add META tags to your Home page, you have the option to apply the META tags to all pages.

Adding META tags in Site view will overwrite any existing keywords for that page entered through Site Options.

Note: that the accepted character set for Meta Tags is ASCII and ASCII Extended.

When you publish your site remotely, you have the possibility to create a map of your site's URLs to be included in search engines databases. See Creating a Site Map for Search Engines.

Setting Page Protection Options

You can set protection options for pages to retain control over each page's content.

Click the Protection Options button to apply the following protection options:

  • From deletion. Prevents the page from being deleted or removed from the SiteStructure.
  • From copying. Prevents the page and its content from being copied.
  • From move. When this option is checked, the page cannot be cut and then pasted elsewhere in the SiteStructure.
  • From adding child page. Ensures that new pages cannot be created under the current parent page in the SiteStructure.
  • Protect layout from editing. Prevents the layout from being modified or resized and protects objects within the layout from being modified.
  • Allow text editing in layout. Allows only the text within a locked layout to be edited.
  • Protect MasterBorder from editing. Prevents the MasterBorder from being modified or resized and protects objects within the MasterBorder from being modified.
  • Allow text editing in MasterBorder. Allows only the text within a locked MasterBorder to be edited.
  • Site Protection. Opens the Site Protection button of the Current Site Options dialog so that site-wide protection options can be set.

Changing Backup Settings

From the Tools menu, choose Options > Current Site and click the Backups tab.

  • Publish Profile used to store site backups. Select a Publish Profile for storing site backups.
  • Repository Path. Enter the path where site backups will be stored in the selected Publish Profile.

Note: The backup repository contains sensitive information. For security purposes, the repository path should not be accessible for browsing over the Internet.

  • Alert me when the site backups exceed. Enter a maximum value (in megabytes) of server space for site backups.
  • Total number of site backups. Specify a maximum number of backups that can be stored in the Backup Manager. You will be prompted to delete previous backups when you exceed the maximum number of backups allowed.
  • Naming convention. Choose a preferred naming convention for site autosaves. Select a plain format or one that includes the date and time from the drop-down list.
  • Autosave location. NetObjects Fusion saves autosave files in the \User Sites\sitename\Autosaves folder by default. To change the location of the autosave files, type a new path name in the Autosave location field, or click Browse and select a new location.
  • Total size of site autosaves. Enter a maximum value (in megabytes) of hard disk space to be allocated for site autosaves.
  • Total number of site autosaves. Indicate the number of autosaves you want NetObjects Fusion to keep. The oldest autosaves are overwritten as newer autosaves are created. The default is 4 autosaves; if you have adequate disk space, you can increase this number.

Adding a Page

  1. In Site view,select the page you want to be the parent of the new page.
  2. Click the New Page button on the views bar.

In Site view, the new page appears beneath the selected page. The new page is named Untitled followed by a number, which indicates the order in which new pages were added.

Site visitors may not be able to get to the new page unless navigation is set up in the MasterBorder of the parent page to include the child page. It is also a good idea to set the navigation on the child page to include its parent so site visitors can get back to the previous page.

New Page Templates

You can now select from a curated list of new page types that are inserted, preconfigured for our new Grid System, and ready to be populated with your own text and images.

To add a new Page Template:

  1. In Site view, select the page you want to be the parent of the new page.
  2. Click the More button under the New Page button on the views bar.

New-page-templates.jpg

  1. The available Page Templates appear in a flyout menu.
  2. Select the Page Template you would like to add.
  3. The new Page Template will be imported into your website beneath the selected page. The new pages will be named Untitled.

You can select the following New Page Templates:

New Blank Page Contact Form Image Carousel Image Gallery
Blank.png Contact Form.png Image Carousel.png Image Gallery.png
Image Single Double Image Triple Scatter Image Triple Map
Image Single Double.png Image Triple Scatter.png Image Triple.png Map.png
PayPal Text Double Text Single Double Text Single
PayPal.png Text Double.png Text Single Double.png Text Single.png
Text Triple Fill Text Triple Outline Text Triple
Text Triple Fill.png Text Triple Outline.png Text Triple.png

Special Pages

Some of the available Page Templates may include Snippets or other elements preconfigured on the page.

  • The Contact Form page includes a form.
  • The Image Carousel page includes an image Carousel.
  • The Image Gallery page includes an image gallery.
  • The Maps page includes a Google map.
  • The PayPal page contains a small ecommerce shop with PayPal buttons.

For information on editing the Snippets please see Using the Web Snippet.

Copying and Pasting Pages

You can copy pages in Site view and paste them anywhere in the SiteStructure.

  1. Select the page or pages you want to copy and press Ctrl+C.
  2. Select the page to be the parent of the copied pages and press Ctrl+V.

The copies are pasted into the SiteStructure as children of the selected page.

Deleting a Page

  1. In Site view, select the page or pages you want to delete, right-click the page icon, and choose Delete Page from the shortcut menu.
  2. Click Yes to confirm the deletion.

If you delete a page that has children, the child pages move up to the level of the deleted page. Deleting a page cannot be undone. You cannot delete the Home page.

Moving a Page

When you move pages in Site view, NetObjects Fusion updates all affected links within the site. If you move a page that has children, the pages retain their relationship.

  1. In Site view, select the page or section you want to move. You cannot move the Home page or noncontiguous pages.
  2. Drag the page to the target page, where it becomes a sibling, a child, or a parent in its new location.

As you drag the page, a colored outline highlights the target page. A triangle to the left or right of the target page's border indicates the moved page will be a sibling; a triangle below the target page's border indicates the moved page will be a child; and a triangle above the target page's border indicates the moved page will be a parent. If you want to move a page so it will be the child of a page that already has children, target the sibling page. You can cut and paste to move noncontiguous pages.

Replacing the Home Page

You cannot move the Home page, but you can move a page to be the parent of the Home page.

  1. In Site view, select the page you want to become the new Home page.
  2. Drag the page to the Home page until you see the colored triangle above the Home page.
  3. When you release the mouse button, the new page becomes the parent of the Home page.
  4. If you move a page that has children to be the parent of the Home page, the Home page becomes the sibling of the child pages.

Renaming Pages

By default, NetObjects Fusion uses the page name on banners and navigation buttons that identify the page. When you publish your site, NetObjects Fusion uses the page name as the HTML file name for the page. It also uses the page name when it creates links to the page.

NetObjects Fusion converts spaces and non-alphanumeric characters except periods (.) and hyphens (-) in the page name to hyphens in the HTML file name.

If you give two pages the same name and they are published in the same folder, NetObjects Fusion adds a numeral to the file name when it generates the HTML files for the second and any additional pages. For example, if you have two pages named Great, NetObjects Fusion creates Great.html and Great1.html. This only affects the page names in Publish view.

You can change the name directly on the page icon or in the Page name field on the Page tab of the Properties panel.

To rename a page on the page icon:

  1. In Site view, click the page name text and type a new name.
  2. Press Enter or click outside the page icon to enter the name.

Once in this edit mode, you can tab between sibling pages to edit their names. NetObjects Fusion remains in edit mode until you press Enter. If a page has no siblings, pressing Tab moves the text edit selection to the page's parent.

To rename a page on the Properties panel:

  1. Select the page you want to rename.
  2. Edit the text in the Page name field on the Page tab of the Properties panel.
  3. Press Tab or click outside the panel to enter the new name.

If several pages are selected, you can change the page name on the Selected Pages tab of the Properties panel. See Setting Properties for a Group of Pages.

Using Custom Button and Banner Names and File Extensions

By default, banners and navigation buttons use the page name. If you prefer, you can specify different names. If you have a long page name, you can break it into two lines.

To specify custom page names in Site view:

  1. Select the page you want to work with.
  2. On the Page section of the Properties panel, click the Custom Names button.
  3. In the Custom Names dialog, type the custom names you want to use.
  • Navigation button. Appears on navigation buttons leading to this page. To add a second line of text, press Enter after the first line.
  • Banner. Appears in the page's banner. To add a second line of text, press Enter after the first line.
  • File extension. Page files usually have an .htm or .html extension. A page sometimes requires a different extension to function with specific server software. For example, pages for secure locations use the extension .shtml.

The extension you choose for this page overrides the extension you specify in Publish view. See Setting Up to Publish Locally.

  1. When you finish entering names, click OK.

You can also rename buttons and banners in Page view using the object's Properties panel. See Changing a Button's Name and Changing the Banner Text.

Setting Up the Site View Display

You use options on the View menu in Site view to set up your Site view display.

You can change the Site view orientation and background color and color code the page icons. These settings are strictly for working in Site view. They have no effect on the published site.

  • To change orientation, from the View menu, choose Orientation and then choose Vertical or Horizontal.
  • To change background color, from the View menu, choose Background Color and select a new color from the Color Picker.
  • To set up page icon color codes, see Setting Site Management Properties.

Collapsing the SiteStructure Display

By collapsing the display of the SiteStructure, you hide the child pages of a selected page, displaying only the page icons you want to see. A page with hidden child pages displays a plus symbol beneath its icon.

To collapse the display of child pages, click the triangle beneath the parent's page icon. To expand the display to see child pages again, click the plus sign.

You can also collapse the display by selecting a parent page and pressing Tab. To expand the display, press Tab again.

The Structure and Outline views display the same expanded and collapsed pages. If you change the child pages hidden and shown in one view, the other view reflects your changes.

Working in Site Outline View

Site Outline view displays the Site Structure in outline format, including a table of the properties child name, page type, status, publishing status, and comments of the child pages of the currently selected page. If the selected page has no children, the table describes the selected page itself.

To switch to Outline view:

  1. In Site view, click the Outline tab.

Like Site Structure view, Site Outline view shows if a branch of the site is collapsed. A collapsed branch is indicated by a plus sign to the left of the page icon; an expanded branch is indicated by a minus sign.

  • To expand a branch, click the plus sign to the left of a page.
  • To collapse a branch, click the minus sign to the left of a page.

In Outline view you can sort the child pages by their properties so you can quickly identify pages with common characteristics.

Click the heading of the column you want to use to sort the list.

NetObjects Fusion sorts the list in ascending (A-Z) order. To sort the list in descending (Z-A) order, point to the column heading and press Shift+Click.

Printing the SiteStructure

In Site view, you use the Print command on the File menu to print the SiteStructure view of your site or of a section. You cannot print the Site Outline view. The printed structure shows the same magnification, colors, orientation, and expanded or collapsed child pages that you see on the screen. The printout shows the site name in the header and the number of site pages in the footer.

  • To print the entire site, select the Home page, or click All in the Print dialog.
  • To print a specific page and its children, select the top-level page or a section, or click Selected page and its children in the Print dialog.
  • To view what will be printed, select Print Preview from the File menu. Select Close to return to Site view.
  • To fit a large site on a single page, from the File menu, choose Print Setup and select the Print to fit option in the Print Setup dialog.

Saving Your Work

To save your work, choose Save Site from the File menu. NetObjects Fusion also has an auto save feature that saves your work each time you change views. See Setting Program Options.

Backing Up Your Site

You can back up your site manually or automatically. To make a manual backup:

  1. From the File menu, choose Save Site As.

The Save Site As dialog appears.

  1. Type a descriptive name for your backup file and select a location.
  2. Click Save.

NetObjects Fusion creates a copy of the.nodfile in the location you specified and automatically opens that file.

The backup you make with the Save Site As command does not collect all assets and make all links relative. Your backup will still refer to assets and components in the original site file folder. To make a backup with assets and relative links, export your site file as a template, as described in Working with Templates.

For information on automatic site file backups, see Setting Backup Options.

Deleting a Site

If you want to delete an existing site, navigate to the location where you saved the site that you want to remove. By default your site folder is saved inside the \User Sites directory, but you can store the site in any location on your local computer.

  1. In the User Sites directory, select the folder with the site that you want to remove.
  2. Right-click on the site's name and choose Delete from the context menu.
  3. Click Yes to confirm the deletion.

Changing the User Sites Default Location

When you create a site, NetObjects Fusion will place it by default under the User Sites folder.

However, you can change this default location and set a new location to which your site should be saved. To do that:

  1. From the File menu, select Change Location.
  2. The Browse for Folder dialog will appear, having the User Sites folder set as default location.
  3. To set a new location, choose another folder where your sites will be kept from now on.
  4. Click OK.

Setting Options for the Current Site

Site options help you manage your site. You can change these settings from any view. Changes take place as soon as you click OK to close the Current Site Options dialog.

These options apply only to the current site. To set options that apply to all sites, see Setting Application Options.

Changing General Settings

From the Tools menu, choose Options > Current Site.

The General tab of the Current Site Options dialog appears.

  • Site name. The name assigned to this site when it was created. You cannot change this setting.
  • SiteStyle. The style currently assigned to this site. To change the SiteStyle go to Style view. See Using SiteStyles.
  • Number of pages. Pages currently in this site. This setting is updated when you add or delete pages.
  • New page size. Default width and height for pages you add to the site. Changing this setting does not change the size of existing pages in the site.
  • Site Generation
    • Click the Change button to select a different HTML output for the site.
    • Scripts. Select the default scripting language (ASP or PHP) used for NetObjects Fusion components. Check with your Internet service provider to determine which option is appropriate for your hosting environment.
    • Enable AJAX Technology

You also have the possibility to enable the Ajax technology on your site. By using the advanced Ajax technology, you have the advantage that when you reload a page, only the new parts/objects of the page will reload, not the entire page. This makes the reloading process much quicker. Enabling this technology is also useful if you decide to include Data Sources to your site. This means that, whenever you refresh/reload your page, the information updated on the site's page will be provided by the Data Sources on the server. The Ajax technology makes it possible, when reloading the page, to only reload the new information taken from the Data Source, not the entire page.

  • Characters. You can choose a character set from the drop-down list. See Setting the Site's Character Set.
  • Formatting. You can choose HTML or cascading style sheets (CSS). See Selecting HTML or Cascading Style Sheet Text Formatting .
  • Quotes. Select Straight or Curly quotes for the site's text objects.
  • HTML Options. Click this button to define characteristics of the HTML generated when you publish your site. See Setting HTML Options .
  • Variable Options. Click this button to enable variable substitution. You can also add a prefix and/or suffix to NetObjects Fusion 's variable syntax that will not conflict with your defined variables.

Setting Page Protection Options

You can set protection options for pages to retain control over each page's content. Click the Protection Options button to apply the following protection options:

  • From deletion. Prevents the page from being deleted or removed from the SiteStructure.
  • From copying. Prevents the page and its content from being copied.
  • From move. When this option is checked, the page cannot be cut and then pasted elsewhere in the SiteStructure.
  • From adding child page. Ensures that new pages cannot be created under the current parent page in the SiteStructure.
  • Protect layout from editing. Prevents the layout from being modified or resized and protects objects within the layout from being modified.
  • Allow text editing in layout. Allows only the text within a locked layout to be edited.
  • Protect MasterBorder from editing. Prevents the MasterBorder from being modified or resized and protects objects within the MasterBorder from being modified.
  • Allow text editing in MasterBorder. Allows only the text within a locked MasterBorder to be edited.
  • Site Protection. Opens the Site Protection button of the Current Site Options dialog so that site-wide protection options can be set.

Changing Backup Settings

From the Tools menu, choose Options > Current Site and click the Backups tab.

  • Publish Profile used to store site backups. Select a Publish Profile for storing site backups.
  • Repository Path. Enter the path where site backups will be stored in the selected Publish Profile.

Note: The backup repository contains sensitive information. For security purposes, the repository path should not be accessible for browsing over the Internet.

  • Alert me when the site backups exceed. Enter a maximum value (in megabytes) of server space for site backups.
  • Total number of site backups. Specify a maximum number of backups that can be stored in the Backup Manager. You will be prompted to delete previous backups when you exceed the maximum number of backups allowed.
  • Naming convention. Choose a preferred naming convention for site autosaves. Select a plain format or one that includes the date and time from the drop-down list.
  • Autosave location. NetObjects Fusion saves autosave files in the \User Sites\sitename\Autosaves folder by default. To change the location of the autosave files, type a new path name in the Autosave location field, or click Browse and select a new location.
  • Total size of site autosaves. Enter a maximum value (in megabytes) of hard disk space to be allocated for site autosaves.
  • Total number of site autosaves. Indicate the number of autosaves you want NetObjects Fusion to keep. The oldest autosaves are overwritten as newer autosaves are created. The default is 4 autosaves; if you have adequate disk space, you can increase this number.

Backup and Autosave Settings

With NetObjects Fusion, you can create multiple publish profiles and designate a specific profile for staging site backups. As a safeguard, NetObjects Fusion automatically saves backup copies of your site each time you close the application. When configuring site options, you can specify the publish profile to be used for site backups and the location where site backups are stored. You can also specify size and/or number limitations for backups and site backups to avoid running out of server or hard disk space. From the Tools menu, choose Options > Current Site and click the Backups tab:

  • Publish Profile used to store site backups. Select a Publish Profile for storing site backups. For information on creating publish profiles, see Define Server Profiles.
  • Repository Path. Enter the path where site backups will be stored in the selected Publish Profile.

Note: The backup repository contains sensitive information. For security purposes, the repository path should not be accessible for browsing over the Internet.

  • Alert me when the site backups exceed:
  • Total size of site backups. Enter a maximum value (in megabytes) of server space for site backups.
  • Total number of site backups. Specify a maximum number of versions that can be stored in the Backup Manager. You will be prompted to delete previous versions when you exceed the maximum number of versions allowed.

Local Autosaves

  • Naming convention. Choose a preferred naming convention for site autosaves. Select a plain format or one that includes the date and time from the dropdown list.
  • Autosavelocation. NetObjects Fusion saves autosave files in the\User Sites\sitename\Autosaves folder by default. To change the location of the autosave files, type a new path name in the autosave location field, or click Browse and select a new location.
  • Total size of site autosaves. Enter a maximum value (in megabytes) of hard disk space to be allocated for site autosaves.
  • Total number of site autosaves. Indicate the number of autoaves you want NetObjects Fusion to keep. The oldest autosaves are overwritten as newer autosaves are created. The default is 4 autosaves; if you have adequate disk space, you can increase this number.

Setting Site Traffic Options

Site Traffic Options offers you the possibility to keep track of your Web site's visitors. This service is provided by Google Analytics. Google Analytics makes the analysis of your site's pages and provides statistics for a certain period of time. The tracking is done for all pages of the site, including external links and file links.

Enabling the Google Analytics Service

To enable the Google Analytics service:

  1. From the Tools Menu, choose Options > Current Site.
  2. The Current Site Options dialog appears.
  3. Click the Site Traffic tab.
  4. Click the "New Account" button to create a Google account.

Note: Your Google Account will give you access to Google Analytics.

If you already have a Google account, after you click the "New account" button, click the "Sign in here" link to sign up to Google Analytics.

  1. Once you have a Google Account, you can sign up to Google Analytics and activate the service.
  2. Provide your Web site details.

Note: After you finish signing up to Google Analytics, it is not necessary to copy code on every page of your NetObjects Fusion Web site.

NetObjects Fusion only needs the ID of the created account. The Google Account ID is also available on the Edit Account and Data Sharing Settings section. The Account ID helps the Google Analytics service to keep track of your site's visitors.

  1. Return to NetObjects Fusion to enable the site traffic option.
  2. On the Site Traffic tab, type in the Account ID in the corresponding field.
  3. Check the "Enable Google Analytics for statistics tracking" box.
  4. Click OK.

After you publish your site remotely, the statistics tracking will begin automatically.

Viewing Statistics with Google Analytics

  1. In NetObjects Fusion, open the site for which you want to check the visitor statistics.
  2. From the Tools Menu, choose Options > Current Site. The Current Site Options dialog appears.
  3. Click the Site Traffic tab.
  4. Click the "View Statistics" button.
  5. Sign in to your Google Analytics account.
  6. Click the "Check Status" button.

Edit the HTML code of Google Analytics

The Google Analytics option is also visible and editable using the HTML Code Editor panel in NetObjects Fusion . The Google Analytics code is displayed in the Body End section in the HTML Code Editor dialog.

To modify the Google Analytics code:

  1. In Page View, from the View menu, select More Panels > HTML Code Editor. The Inspector HTML dialog appears.
  2. Click the bodyEnd button. The Inspector HTML dialog displays the Google Analytics HTML code.
  3. After you modify the Google Analytics code, click the Save button.

Warning: Do not delete the comments added to the Google Analytics code displayed in the HTML Body End section. If necessary, you can roll back to the original code generated by Google Analytics. To roll back to the original code:

  1. From the Tools menu, select Options > Current site.

The Current Site Options dialog appears.

  1. Click the Site Traffic tab.
  2. Click the Update all Pages button to roll back to the original code.
  3. Click OK.